Back to overview
Maintenance
Major Problem
Apr 19, 2026 at 7:06pm UTC
–
Apr 23, 2026 at 9:06pm UTC
Affected services
RoShop Support Bot
roshoprblx.store
Resolved
Apr 23, 2026 at 9:06pm UTC
Maintenance ended
Affected services
Created
Apr 19, 2026 at 7:06pm UTC
Website and Support Bot are both down
Affected services